MHW Builder Patch notes 2.5.x

General:

Web version:

  • Added 502 (-44) MR Kulve Taroth weapons.
  • Kulve Taroth weapons should use proper sharpness data
  • Attack Charm 4 > 5
  • Evasion Charm 4 > 5
  • Added Nami gamma.
  • Added USJ MR set.
  • Added Kulve Taroth alpha and beta sets.
  • Fixed the sorting issue for Set Searcher.
  • Fixed the Descending Thrust first tick being not affected by Airborne skill.
  • Fixed the Descending Thrust last tick (for Finisher) having wrong MV value (16 > 36).
  • True Critical Element (Status) should have more priority in calculations than regular Critical Element (status).
  • Elemental Effectiveness UP shouldn’t be affecting status damage anymore.
  • Abnormal Status Effect S/L and Elemental Up S/L songs were merged (same buff button, but effect will depend on status / element damage on the weapon).
  • Fixed an issue when adding the set, containing an empty slot could cause an error during server sync.
  • Fixed an issue with Public Profiles, not loading anymore.
  • Adamantine Charm should be interacting with sharpness values as intended.
  • Corrected enrage values for Bazel, Behemoth, Deviljho, Savage Deviljho, Gold & Silver Rats, Lavasioth, Lunastra, Nergi & Ruiner Nergi, Uragaan, Vaal & Blackveil Vaal, Xeno’Jiiva, Zorah
  • Pukei Hat alpha and gamma Undefined Skill > Survival Expert

Android / IOS Apps:

  • Added 502 (-44) MR Kulve Taroth weapons.
  • Kulve Taroth weapons should use proper sharpness data
  • Attack Charm 4 > 5
  • Evasion Charm 4 > 5
  • Added Nami gamma.
  • Added USJ MR set.
  • Added Kulve Taroth alpha and beta sets.

 

 

ToDo List:

19 comments

Skip to comment form

    • Qc on 24th April 2020 at 12:41 am
    • Reply

    any idea why my decorations are not attaching to the armor and weapon after i have found the set i want, they will just show “No Jewel” and only like a couple are attached, it happened after the update, maybe i might of pressed something or who knows, thanks

    1. the set?

  1. For the Ingot Mail Alpha/Beta +, the skills are wrongly put as Thunder Attack. The correct skills are Thunder Resistance.

    1. Sure, thanks.

    • Fire-Dragon-DoL on 27th April 2020 at 5:46 am
    • Reply

    Hello!
    In the last 2 days I wasn’t able to access to your great builder.

    I debugged the problem a little bit and figured out the following: in the file clipboard.js, line 12, the “document.body” is null when invoking appendChild.
    This is the code snippet:

    window.Clipboard = (function(window, document, navigator) {
    var textArea,
    copy;

    function isOS() {
    return navigator.userAgent.match(/ipad|iphone/i);
    }

    function createTextArea(text) {
    textArea = document.createElement(‘textArea’);
    textArea.value = text;
    document.body.appendChild(textArea);
    }

    My best guess is the function window.Clipboard is being invoked before the page has fully loaded.

    Finally, same file on line 47 I see: Clipboard.copy(‘text to be copied’); (last line in the file)

    I think this is a test line that’s been put at the bottom during some interactive testing phase. This is also the possible source of the bug, because it’s invoked at the end of the file, so outside anything and as soon as the file it’s loaded.

    clipboard.js:12 Uncaught TypeError: Cannot read property ‘appendChild’ of null
    at createTextArea (clipboard.js:12)
    at Object.copy (clipboard.js:37)
    at clipboard.js:47

    This is the stacktrace.

    Hope this was helpful!

    1. That’s on MacOS or IOS?

        • Francesco on 28th April 2020 at 8:27 pm
        • Reply

        This is on the web version, I tried it both on Windows 10 and Ubuntu 18.04, both in Chrome (extensions installed) and Firefox (no extensions installed)

        • Francesco on 28th April 2020 at 8:28 pm
        • Reply

        And it’s for the vanilla version, not the Iceborne one!

        1. Should be fine now.

    • Daeion on 28th April 2020 at 9:31 pm
    • Reply

    Hello,

    Trying to access the Vanilla Builder via Chrome and FireFox on Windows 10 and it doesn’t advance past Monster data loaded… I’ve tried normal and incognito/private mode.

    1. I accidentally updated /mhwb/ databases during MR Kulve update, which caused multiple errors on startup, should be fine now.

    • Mikhail on 28th June 2020 at 1:43 pm
    • Reply

    Hey any idea why this latest version isn’t showing up in the iOS App Store?

    1. Apple store changes politics about web-based apps, I hope everything going to be fine with Alatreon update.

    • Kiki on 2nd July 2020 at 2:08 pm
    • Reply

    The Iceborne Builder unfortunately does not seem to load on the web version. I tried with Chrome, Firefox and Edge (all with Adblock disabled) and tested with multiple laptops. It just freezes while the message “In case if something is not updating, please try: …” is displayed (refreshing did not fix the problem). I went on reddit earlier to see if it is just me but every person that answered me confirmed they encountered the bug too.

    1. Should be fine now.

    • DANIEL on 6th July 2020 at 10:56 pm
    • Reply

    can’t find blackveil hazak armor

    1. Fellshroud

  2. Hey there, not sure if it’s just me or if others are having a similar issue, but regardless of which browser I use, the Web version of the Iceborne builder seems to sort-of freeze. Im not using an adblock, and everything on the application loads up so that I can view it with the default layout (http://honeyhunterworld.com/mhwbi/?1,1,1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,3:0:0:0:0:0:0) but beyond that all I can do is hover over the default skills to see their information, and expand the menu tab. I cannot click to change anything, nor can I access any of the menu tabs. Maybe there is some setting I’m not aware of or something, but it was working fine a little while ago, and now I can’t access anything. Just thought I would throw it out there.

    1. Yeah, it was just me. Turns out my antivirus was overriding all of my browser settings, so once I turned off my antivirus completely, the Iceborne Web application worked as intended. Sorry for the initial post, I would delete it if I could.

Leave a Reply

Your email address will not be published.

Top